Главная Пк И Mac Чувствительны ли электронные письма к регистру?

Чувствительны ли электронные письма к регистру?



Существует много недоразумений по поводу того, чувствительны ли адреса электронной почты к регистру или нет. Некоторые говорят, что да, а другие утверждают, что нет. Итак, кто прав? В этой статье мы узнаем, чувствительны ли к регистру адреса электронной почты или нет.

Чувствительны ли электронные письма к регистру?

Что делает адрес электронной почты?

Адрес электронной почты состоит из трех частей - локальной части (также известной как имя пользователя), знака @ и доменной части. Каждая часть имеет свою роль и подчиняется собственному набору правил. Вот краткий обзор.

Согласно стандарту локальная часть адреса электронной почты может иметь длину до 64 символов и может состоять из ограниченного набора символов. К ним относятся прописные и строчные буквы латинского алфавита, цифры от 0 до 9, точки и специальные символы. К специальным символам относятся `[email protected] # $% ^ & * () _- + = [] {} ~. Подключается к доменной части знаком @.

Доменная часть может иметь длину до 255 символов. Он может содержать буквы латинского алфавита (как нижний, так и верхний регистр), цифры от 0 до 9 и дефис. Дефис не может начинать или заканчивать доменную часть.

Также могут использоваться международные символы, но об этом позже.

Это чувствительно к регистру?

Правильный ответ на этот вопрос - и да, и нет. В соответствии с RFC 5321 , локальная часть адреса электронной почты чувствительна к регистру. Это означает, что теоретически [защищенная электронная почта] - это не то же самое, что [защищенная электронная почта]. Однако провайдеры электронной почты могут рассматривать локальные части как с учетом регистра, так и без учета регистра.

Например, [защищенная электронная почта], [защищенная электронная почта] и [защищенная электронная почта] теоретически являются разными адресами электронной почты. Легко увидеть, как это могло бы создать проблемы и ухудшить взаимодействие с пользователем, если бы почтовый сервер решил рассматривать локальные части как чувствительные к регистру. Поэтому многие провайдеры обрабатывают локальную часть адреса электронной почты как нечувствительную к регистру.

как искать на странице facebook

Что касается доменной части, RFC 1035 оговаривает, что он всегда нечувствителен к регистру. Это означает, что вы можете написать его в нижнем регистре, в верхнем регистре или в любой их комбинации, и ваша электронная почта попадет на тот же адрес. На практике [защищенный адрес электронной почты], [защищенный адрес электронной почты] и [защищенный адрес электронной почты] являются одним и тем же адресом электронной почты.

На практике

Хотя адреса электронной почты лишь частично чувствительны к регистру, в целом можно считать их нечувствительными к регистру. Все основные провайдеры, такие как Gmail, Yahoo Mail, Hotmail и другие, рассматривают локальные части адресов электронной почты как нечувствительные к регистру. При этом вам следует проверить правила провайдера электронной почты, с которым вы хотите создать электронное письмо.

В связи с предыдущим пунктом вышеупомянутый RFC 5321 рекомендует создавать новые адреса электронной почты только строчными буквами, чтобы избежать возможной путаницы и проблем с доставкой.

С другой стороны, если у вашего друга или коллеги есть адрес электронной почты, состоящий из символов верхнего и нижнего регистра, рекомендуется указать его таким, каким вы его отправляете по электронной почте. В противном случае электронное письмо может не быть доставлено. Однако это не проблема основных поставщиков услуг электронной почты, таких как Gmail, Yahoo Mail, Hotmail и других.

Кроме того, Gmail нечувствителен к точкам в локальной части электронного письма, когда дело касается идентификации учетной записи пользователя. Это означает, что при наличии учетной записи [защищенный адрес электронной почты] вы не сможете зарегистрировать [защищенный адрес электронной почты] или [защищенный адрес электронной почты].

Интернационализация

Первоначально адреса электронной почты могли быть зарегистрированы только с использованием букв латинского алфавита, цифр и ограниченного набора специальных символов ASCII. Тем не менее IETF (Инженерная группа Интернета) впоследствии разработала правила и стандарты для включения международных символов.

RFC6530 был первым, кто включил и отрегулировал использование международных символов. RFC6531 расширил правила и стандарты. Впоследствии правила и стандарты были обновлены через RFC6532 а также RFC6533 .

Теперь вы можете зарегистрировать адрес электронной почты, используя широкий спектр алфавитов, символов и скриптов. Некоторые из наиболее широко используемых включают латинские символы с диакритическими знаками, греческий алфавит, традиционные китайские иероглифы, японские иероглифы (хирагана, катакана и кандзи), кириллица, несколько индийских шрифтов, а также ряд других.

Включение и совместимость международных адресов электронной почты варьируется от поставщика к поставщику. Даже некоторые из крупнейших провайдеров не полностью совместимы с международными адресами. Например, Google позволяет отправлять электронные письма на международный адрес, но не позволяет создавать их. Outlook 2016 имеет аналогичную функциональность.

Заключение

В отличие от части имени домена, локальная часть адреса электронной почты чувствительна к регистру. При этом многие провайдеры электронной почты предпочитают игнорировать чувствительность к регистру локальной части по практическим соображениям и поощряют людей создавать электронные письма только с символами нижнего регистра.

Интересные статьи

Выбор редакции

Скачать Скачать cPro__Bento Skin для Winamp
Скачать Скачать cPro__Bento Skin для Winamp
Загрузите cPro__Bento Skin для Winamp. Здесь вы можете скачать скин cPro__Bento для Winamp. Все кредиты принадлежат оригинальному автору этого скина (см. Информацию о скине в настройках Winamp). Автор:. Скачать 'Скачать cPro__Bento Skin для Winamp' Размер: 255,85 Kb РекламаPCRepair: Исправить проблемы с Windows. Все они. Ссылка для скачивания: Нажмите здесь, чтобы загрузить
Как собрать компьютер: онлайн-руководство по созданию собственного компьютера с нуля
Как собрать компьютер: онлайн-руководство по созданию собственного компьютера с нуля
Мало что может сравниться с удовлетворением, которое вы получаете от сборки собственного ПК с нуля или от модернизации существующей модели. Поскольку цены на компьютеры ниже, чем когда-либо, это может показаться ложной экономией, но посмотрите глубже, и вы увидите
Как изменить свой профиль Netflix на телевизоре Samsung
Как изменить свой профиль Netflix на телевизоре Samsung
Netflix с более чем 150 миллионами подписчиков является одним из ведущих потоковых сервисов в мире. Благодаря простому в использовании интерфейсу и относительно недорогой модели подписки его популярность неудивительна. Хотя многим пользователям нравится смотреть
Как скопировать файлы с ПК с Windows на Linux
Как скопировать файлы с ПК с Windows на Linux
У большинства домашних пользователей есть система с двойной загрузкой, которая может загружаться из Linux, например Ubuntu, или запускаться из Windows. Этот сценарий, безусловно, является самым простым способом передачи файлов из Windows в Linux. Однако другие (деловые или личные)
Архив меток: Windows 10 build 10586 iso
Архив меток: Windows 10 build 10586 iso
Кто такой Тим Кук? Мы исследуем генерального директора Apple, сменившего Стива Джобса.
Кто такой Тим Кук? Мы исследуем генерального директора Apple, сменившего Стива Джобса.
Тим Кук одновременно является одним из самых заметных и анонимных людей на планете. Попросите кого-нибудь рассказать о нем несколько фактов, и он, скорее всего, будет ошеломлен. 57-летний мужчина попадает в заголовки новостей как
Как заставить Windows 10 отображать знакомые значки рабочего стола
Как заставить Windows 10 отображать знакомые значки рабочего стола
Давайте посмотрим, как вернуть классические значки на рабочий стол в Windows 10.